Лінукс для людей/Writer

Матеріал з Вікіпідручника
Перейти до навігації Перейти до пошуку

Що таке Writer?[ред.]

Writer – це текстовий процесор у складі офісних пакетів Apache OpenOffice чи LibreOffice. Крім звичайних можливостей текстового процесора (перевірка орфографії, тезаурус, розстановка переносів, пошук і заміна, автозаміна, автоматичне створення змісту та індексів), Writer забезпечує ще низку важливих можливостей:

  • шаблони та стилі;
  • потужні методи розмітки сторінок, включно з вставками, стовпцями і таблицями;
  • вбудовування або зв’язування графічних об’єктів, електронних таблиць, інших об’єктів;
  • вбудовані засоби малювання (завдяки наявності графічного редактора Draw);
  • головні документи, які використовуються для об’єднання набору документів у один документ;
  • відслідковування змін та версіонування документів;
  • інтеграція з різними джерелами інформації: базами даних, бібліографічними базами тощо;
  • експорт у формат PDF із закладками;
  • імпорт із великої кількості форматів (включно із Microsoft Word Document різних версій (*.doc, *.docx));
  • збереження у різних форматах (включно із Microsoft Word Document різних версій (*.doc, *.docx));

та інші можливості.

Також у офісних пакетах LibreOffice та Apache OpenOffice реалізована можливість встановлювати доповнення, які розширюють базову функціональність. Для використання із програмою Writer можна рекомендувати такі доповнення:

  • Мовні інструменти (LanguageTool) - містить засоби для граматичного аналізу тексту
  • MultiSave - дозволяє одночасно зберігати документ у кількох форматах (наприклад, ODT, DOC і PDF)
  • Набір знаків небезпеки (Clipart gallery of danger signs)

Крім того, є спеціальні пакети доповнень для використання у різних галузях, наприклад:

  • Dmaths - набір інструментів для математичних текстів, дозволяє спростити додавання у тексті математичних формул, малювання геометричних фігур тощо.
  • Chemistry - дозволяє вставляти у документ зображення хімічних формул, згенеровані із текстового представлення формул.

Інтерфейс програми[ред.]

На рисунку показано загальний вигляд вікна Writer. Користувачі, знайомі з інтерфейсом Microsoft Office версій старіших за 2007, можуть впізнати знайомі їм елементи: меню програми, панелі інструментів, рядок стану,...

Користувач може налаштувати розміщення всіх цих елементів на екрані та склад інструментів, які на них показано.

Якщо вже порівнювати Writer із Microsoft Word, то слід звернути увагу на кілька особливостей, які відрізняють ці текстові процесори. Перш за все, працюючи із Writer, слід пам’ятати, що він орієнтований на правильне логічне форматування тексту і використання стилів, у той час як Microsoft Word хоч і дозволяє використовувати ці можливості, проте дозволяє користувачеві обробляти текст не розуміючи цих можливостей і не використовуючи їх. Про результат такого редагування говорити зараз не будемо, кожен, мабуть, зустрічався з тим, що для дрібного редагування великої кількості однотипних даних у документі, наприклад, центрування формул, доводиться редагувати кожну формулу окремо. Використання ж стилів і правильне логічне форматування (застосування стилів до елементів тексту) дозволяє зробити такі зміни буквально натисканням кількох кнопок.

Робота з таблицями[ред.]

При роботі з текстовим документом досить часто доводиться мати справу з таблицями, оскільки це досить зручний спосіб подання структурованої інформації.

Роботі із таблицями присвячено ціле меню "Таблиця", з допомогою якого можна додати нову таблицю, вилучити непотрібну таблицю, виділити таблицю для виконання інших дій з нею, об’єднати чи розділити комірки, задати властивості таблиці, такі як колір тла однієї чи кількох комірок, чи всієї таблиці, тип обрамлення і товщину ліній, ширину стовпців, розміщення на сторінці, назву таблиці та параметри вирівнювання.

З тією ж метою можна використовувати контекстне меню, яке викликається натискуванням правої кнопки миші на елементах таблиці.

Розглянемо деякі найчастіше вживані дії з таблицями.

Додавання таблиці[ред.]

Додавання таблиці у текстовому документі можна здійснити кількома способами: за допомогою меню "Таблиця", за допомогою панелі інструментів або за допомогою гарячих клавіш (типово [Ctrl]+[F12]). Правда, ця комбінація клавіш може використовуватися операційним (стільничним) середовищем і виконувати зовсім іншу дію - наприклад у середовищі KDE показує стільницю, сховавши всі вікна. Тож, якщо після натискання цієї комбінації клавіш у вас зник документ і відобразилася стільниця - не лякайтеся, просто натисніть ще раз [Ctrl]+[F12] і змініть налаштування у Writer або користуйтеся іншими методами додавання таблиці.

У Writer починаючи з версії 3.0.0 існує ще одна можливість швидкого додавання таблиці – автозаміна. Для цього використовується послідовність із символів "+" та "=" чи "-". Символом "+" позначаються вертикальні межі стовпців, а "=" (чи "-") відповідно ширину стовпців. Так, якщо ввести

+====+=======================================+===+===+

або

+----+---------------------------------------+---+---+

і натиснути [Enter] отримаємо рядок таблиці із заданими параметрами.

Змінити ширину стовпців після створення таблиці можна з допомогою меню ("Таблиця" -> "Властивості таблиці" у вкладці "Стовпчики") або з допомогою контекстного меню (викликається натисканням правої кнопки мишки на комірці таблиці) "Стовпчик" -> "Ширина" чи "Рядок" -> "Висота".

Можна також скористатися гарячими клавішами. Коли курсор знаходиться у комірці таблиці, натисканням комбінація клавіш [Alt]+[<-] і [Alt]+[->] можна змінювати ширину стовпця, а [Alt]+[↑] і [Alt]+[↓] - відповідно висоту рядка. У деяких конфігураціях замість клавіші [Alt] може для цих дій використовуватися клавіша [Ctrl].

Використання гарячих клавіш може суттєво прискорити роботу із таблицями. Правда, вони не завжди налаштовані оптимально. Змінити призначення гарячих клавіш можна з допомогою меню ("Засоби" -> "Налаштувати" -> "Клавіатура": у розділі "Категорія" вибрати "Таблиця", вибрати відповідну функцію і призначити комбінацію клавіш).

Параметри додавання таблиці можна задати з допомогою меню ("Засоби" -> "Параметри" -> "OpenOffice.Org Writer" (чи LibreOffice Writer) -> "Таблиця" (чи "Table")).

Використання Навігатора при роботі з таблицями[ред.]

Таблиця, так само як і зображення, формули, розділи, закладки, коментарі, є спеціальним об’єктом текстового документа. Для перегляду і роботи з об’єктами документа досить зручно використовувати такий інструмент як Навігатор.

Для виклику Навігатора можна використати меню "Перегляд", стандартну панель інструментів або гарячу клавішу [F5]. Навігатор відображає дерево об’єктів документа подібно до того, як файловий менеджер відображає дерево файлів.

Після додавання таблиці у документі, вона автоматично відображається в Навігаторі у розділі "Таблиці". Він може бути у згорнутому вигляді. Щоб його розгорнути і побачити список таблиць у документі, натисніть стрілочку зліва від назви розділу "Таблиці".

Для швидкого переходу до потрібної таблиці достатньо двічі натиснути ліву кнопку мишки на назві таблиці. При цьому курсор переміститься до обраної таблиці і відкриється панель інструментів "Таблиця", на яку винесено кнопки основних дій з таблицями.

Для більш зручного пошуку таблиці в Навігаторі бажано давати таблицям зрозумілі назви. Якщо таблиця створена із стандартною назвою "Таблиця1", варто змінити її назву (для цього достатньо натиснути на ній у Навігаторі праву кнопку мишки і вибрати "Таблиця" -> "Перейменуати" або у властивостях таблиці).

Зверніть увагу: переміщення курсора в таблицю у вікні редагування не виділяє її у Навігаторі, виділеною залишається та таблиця, з якою виконувалася остання дія у Навігаторі. Тому, при виконанні будь-яких дій з таблицею у Навігаторі (особливо, видалення таблиці), переконайтеся, що ви працюєте з потрібною таблицею.

Додавання та видалення тексту до та після таблиці[ред.]

Досить часто буває така ситуація, що таблиця вставлена на самому початку документа, і у процесі редагування виникла необхідність додати перед таблицею деякий текст. У початківця така ситуація викликає питання, оскільки з допомогою мишки не можливо поставити курсор перед таблицею, щоб звичним способом (натисканням клавіші [Enter]) створити новий абзац. У такому випадку для вставки порожнього абзаца перед таблицею потрібно помістити курсор у першу комірку таблиці перед будь-яким текстом у цій комірці і натиснути [Enter] – буде доданий новий порожній абзац перед таблицею.

Подібна проблема зустрічається також, якщо таблиця є останньою на сторінці і після неї немає абзаца, а потрібно додати текст після таблиці. У такому випадку для додавання порожнього абзаца після таблиці потрібно помістити курсор у останню комірку після будь-якого тексту, який є у комірці, і натиснути [Alt]+[Enter].

Іноді зустрічається ситуація, коли таблиця є останньою на сторінці і порожній абзац після неї переходить на нову сторінку, тобто, у кінці документа з’являється порожня сторінка, яка, власне, там не потрібна. У такому випадку можна видалити зайвий порожній абзац після таблиці. Для цього потрібно помістити курсор у останню комірку після будь-якого тексту і натиснути [Ctrl]+[Shift]+[Del]. Проте, користуватися цією можливістю слід обережно, це може викликати деякі проблеми із подальшим редагуванням документа. Тому, використовувати цю функцію доцільно лише у тому випадку, якщо зберігатиметься остаточний варіант документа і остання порожня сторінка не портібна.

Зверніть увагу: Не рекомендовано починати документ чи закінчувати його таблицею без абзаца на початку сторінки чи вкінці. Це може викликати проблеми при виділенні тексту у процесі редагування. Тому рекомендуємо залишати порожній абзац на початку документа, якщо він починається з таблиці, та вкінці, якщо закінчується таблицею.

Форматування таблиці[ред.]

Форматування таблиці (обрамлення, тло, шрифт тощо) можна виконувати через меню "Таблиця", з допомогою панелі інструментів або з допомогою контекстного меню, яке викликається натисканням правої кнопки мишки на відповідних елементах таблиці.

Крім цього, до таблиці можна застосувати один з наперед визначених наборів параметрів. Для цього потрібно помістити курсор у будь-яку комірку таблиці і у меню "Таблиця" вибрати "Автоформат". У вікні, що відкриється, можна вибрати один із форматів і переглянути зразок оформлення таблиці з таким форматом. Якщо наявні формати не підходять, можна створити власні на основі няавних або з нуля.

Досить часто у початківців виникає питання, як розмістити текст у комірці вертикально. Для цього необхідно використовувати властивості символів - "Символ" у контекстному меню чи меню "Формат" -> "Символи". У вкладці "Позиція" можна задати обертання на 0° (без обертання), 90° чи 270°. У цьому режимі розділяти рядки необхідно з допомогою "переносу рядка" [Shift]+[Enter]. (Якщо розділяти [Enter] ("новий абзац"), то рядок буде розірваний, але текст розміститься у одному рядку.) При цьому слід мати на увазі, що таке форматування не буде коректно збережене у форматі Microsoft Word (*.doc). Також при імпорті з цього формату таке розміщення може відображатися неправильно - замість переносу на новий рядок текст розміщується у тому ж рядку. В такому разі необхідно замінити у комірках "новий абзац" (¶) на "перенос рядка" ([Shift]+[Enter]).

Іноді рядки таблиці не розриваються між сторінками, а переносяться повністю на наступну сторінку. Або на сторінці залишається лише один рядок, а решта таблиці переноситься на нову сторінку. Таке часто буває при імпорті документа з формату Microsoft Word. У такому випадку необхідно перевірити властивості таблиці чи не встановлено у вкладці "На сторінці" -> "Розрив" та у властивостях абзаца у вкладці "Положення на сторінці" -> "Розриви". Якщо вирішити проблему не вдалося, потрібно перевірити стилі абзаца, які використані у таблиці. Подібні проблеми може викликати використання стилю "Заголовок" та похідних від нього. У такому разі потрібно виділити таблицю і застосувати стиль "Вміст таблиці" - як правило, це вирішує проблему.

Досить часто, особливо при формуванні всяких звітів із громіздкими заголовками стовпчиків, використовується такий прийом: у першому рядку таблиці вписуються заголовки, у другому рядку проставляються номери рядків - цифри 1, 2, 3, ... і при переході на наступну сторінку дублюється не перший рядок з громіздкими заголовками, а другий - з цифрами. Таке форматування у Writer "в лоб" зробити не можливо. Але є спосіб зробити це, використовуючи спеціальне розбиття таблиці. Для цього необхідно:

  1. Створити таблицю з необхідною кількістю стовпчиків і рядків (рядків потрібно принаймні на 2 більше, ніж рядків у заголовку)
  2. Сформувати заголовки стовпчиків. Заголовки можуть складатися з кількох рядків і містити об’єднані комірки
  3. Виділити таблицю
  4. У меню "Таблиця" вибрати "Розділити таблицю" і вибрати режим "Заголовок користувача". Після цього отримуємо 2 таблиці: одна із заголовком, інша, відділена порожнім абзацом, порожня. У заголовок потраплять усі рядки, які містять дані без розриву порожнім рядком.
  5. Видалити порожній абзац між отриманими таблицями. (Якщо плануєте експортувати документ у Microsoft Word, цього робити не потрібно, інакше експорт може бути некоректним). Після цього візуально дві таблиці будуть відображатися як одна без розривів. У тому, що ми все ще маємо дві таблиці можна впевнитися з допомогою Навігатора.
  6. Проставити номери стовпчиків у першому рядку другої таблиці (візуально це буде другий рядок суцільної таблиці) та відповідно відформатувати
  7. У властивостях другої таблиці ("На сторінці") вказати "Повторити заголовок", "Перші" 1 "рядки".

Після цього при переході на наступну сторінку здублюється лише рядок з номерами стовпчиків, що і потрібно було отримати.

Виділення таблиці[ред.]

Виділити таблицю чи її частину для виконання певної дії можна кількома способами: з допомогою меню "Таблиця", з допомогою мишки чи з допомогою гарячих клавіш.

З допомогою меню можна виділити всю таблицю.

З допомогою мишки можна виділити частину таблиці, але тут є певні особливості. Якщо ви хочете виділити одну комірку, натисніть на ній ліву кнопку мишки і не відпускаючи її переміщуйте мишку до сусідньої комірки. При цьому, поки мишка переміщується у межах комірки, буде виділятися текст від початку переміщення і до поточного положення. Коли ж мишка перейде у сусідню комірку, виділяться обидві комірки. Якщо необхідно виділити лише одну, не відпускаючи ліву кнопку мишки поверніться на потрібну комірку - виділеною залишиться лише вона. Таким чином можна виділити одну чи кілька комірок у будь-якому місці таблиці.

Якщо необхідно виділити рядок чи стовпчик, помістіть вказівник мишки зліва від необхідного рядка чи зверху від необхідного стовпчика. При цьому вигляд вказівника зміниться на стрілку вправо чи донизу. У такому режимі натискання лівої кнопки виділить весь рядок чи стовпчик. Якщо ж натиснути ліву кнопку мишки і не відпускаючи її переміщувати мишку, то будуть виділятися відповідні рядки чи стовпчики.

При виділенні з допомогою гарячих клавіш є одна особливість, яка спочатку може здаватися незвичною і незручною, якщо користувач хоче виділити весь текст, але з часом виявляється досить зручною. Якщо курсор знаходиться у комірці таблиці, то натискання [Ctrl]+A виділяє текст у цій комірці. Повторне натискання [Ctrl]+A виділяє всю таблицю. Ще одне натискання [Ctrl]+A виділить весь текст. Якщо комірка не містить тексту, то виділяється відразу вся таблиця.

Обчислення у таблиці[ред.]

Досить часто при роботі з таблицями виникає необхідність проводити у них певні обчислення. Звичайно, якщо це складні таблиці або складними є самі обчислення, то краще застосовувати для цього електронні таблиці, які, до того ж, з допомогою механізму OLE можна вбудувати у текстовий документ. Проте, використання вбудованих електронних таблиць для простих обчислень - це, як то кажуть, з гармати по горобцях. Для простих обчислень у звичайних (не інтегрованих з Calc) таблицях передбачена можливість задавати формули для обчислення значень у комірках. Для виклику панелі формул можна натиснути [F2] або просто першим символом у комірці ввести "=". Далі можна працювати з формулою подібно до того, як це робиться у електронних таблицях. Крім простих арифметичних операцій ("+", "-", "*", "/") можна використовувати досить багато вбудованих формул, вибрати які можна з допомогою меню "f(x)" на панелі формул. У цьому списку крім простих часто вживаних функцій суми, округлення, відсотків, кореня і степеня є ще й деякі статистичні функції (мінімальне, максимальне та середнє значення), тригонометричні функції та логічні операції, що дозволяє проводити навіть досить складні обчислення.

Зрозуміло, що всі перераховані функції виконуються лише для числових значень у комірках. Якщо ж у комірці міститься текст, то значення комірки для обчислень вважається нульовим.

Порівняно з деякими іншими текстовими процесорами, при зміні числових значень у комірках таблиці залежні від цих комірок значення перераховуються автоматично. З одного боку це добре, оскільки не потрібно натискати додаткові кнопки, щоб побачити результати змін, проте слід враховувати, що це може призвести до значного сповільнення роботи Writer, якщо у таблиці запрограмовано якісь складні розрахунки. У таких випадках доцільніше вбудовувати електронні таблиці Calс у текстовий документ через механізм OLE.

Друк документа[ред.]

Швидкий друк[ред.]

Для друку всього документа на принтер, який встановлений у системі за умовчанням, просто натисніть кнопку "Друк" на стандартній панелі інструментів – документ буде надруковано.

Вікно "Друк"[ред.]

Для повного керування друком документа необхідно викликати вікно "Друк", яке дозволяє налаштувати додаткові параметри. Для цього у меню "Файл" виберіть пункт "Друк" або натисніть на клавіатурі [Ctrl]+P.

У цьому вікні Ви можете бачити зменшений вигляд сторінок, які вибрані до друку і переглянути їх, користуючись кнопками <| та |> під зображенням. У вкладці "Загальні" ("General") можете вибрати один із встановлених у системі принтерів, на якому буде надрукований документ, та задати властивості друку для цього принтера.

У вкладці "Розміщення" ("Page Layout") можна вказати, скільки сторінок буде надруковано на аркуші та роздрукувати документ у вигляді брошури, задати друк лише лівих або лише правих (парних/непарних, нижніх/верхніх - в залежності від вибраного режиму) сторінок.

Попередній перегляд сторінки[ред.]

Вікно попереднього перегляду сторінки дозволяє побачити, як буде надруковано документ, та відправити документ на друк.

У цьому вікні можна переглядати результат посторінково, або у вигляді розгортки (з допомогою кнопки ) для документів, які друкуються у вигляді книжки, або взагалі кілька сторінок одночасно у вигляді таблиці (з допомогою кнопки ).

Оформлення бібліографічного списку[ред.]

Цей підрозділ присвячено висвітленню варіантів створення та оптимізації оформлення списку використаних джерел та літератури у документах на кшталт рефератів, курсових, дипломних та дисертаційних робіт.

Багаторічний досвід оформлення списку літератури в ручному режимі з постійними змінами порядку використання джерел та літератури по тексту, а також зміною нумерації при додаванні нових елементів, доказує, що на формальне оформлення кінцевого варіанту роботи йде ледь не більше сил та часу, ніж на її фактичне написання. Тому вкрай доцільним вбачається використання автоматичних інструментів оформлення роботи. Наприклад, використання заголовків та, власне, інструментів для оформлення списку літератури.

Використання стандартного інструменту[ред.]

Стандартний інструмент для створення бібліографічного списку та оформлення автоматично-оновлюваних посилань по тексту, доступний через меню Вставка-Оголошення і вказівники

Далі, для створення нового елементу списку літератури слід обрати "Елемент списку літератури". В діалоговому вікні обрати "З поточного документу", далі "створити", вийде нове діалогове вікно у вигляді таблиці з полями для відповідних даних джерела чи літератури.

Для створення розділу з опублікованим списком літератури, слід обрати "Оголошення і вказівники". У діалоговому вікні обрати тип "Бібліографія".

Недоліки стандартного інструменту бібліографії[ред.]

База даних джерел та літератури формується напівавтоматичним способом, шляхом заповнення таблиці діалогового вікна. В наслідок цього, формат бібліографічного запису відрізняється від формату, який вимагають в навчальних закладах і академічних установах України. Крім того, при відсутності інформації у деяких полях, розділові знаки між полями у вихідному бібліографічному записі, з’являються автоматично.

Отже, використання стандартного інструментарію для створення бібліографічних списків в редакторі LibreOffice Writer 4.4.3.2, в українських реаліях, не рекомендується з причини не відповідності вимогам державної атестаційної комісії.

Альтернативний спосіб[ред.]