Blender/Стартовий посібник

Матеріал з Вікіпідручника
Перейти до: навігація, пошук

Цей посібник надає базові навички роботи з 3D редактором Blender версії 2.5 та вище. Основна мета - дати початківцям спробувати Blender на практиці, дати змогу відчути «смак» цього редактора.

Так як інтерфейс Блендера версій 2.5x досить сильно змінився порівняно з інтерфейсом версій 2.4x, даний посібник також знадобиться тим хто вже працював в Blender 2.4x і бажає перейти на версію 2.5x (або вище).

Навігація[ред.]

Ми почнемо розглядати аспекти 3D, реалізовані в програмі, відразу з практики. Все про що нам варто потурбуватися зараз - це положення курсора миші в потрібній частині інтерфейсу, яку ми називаємо Вікно 3D-вигляду (і перевірити, чи включений NumPad на вашій клавіатурі)

Якщо у вас ноутбук (де зазвичай відсутня "цифрова" клавіатура), зайдіть в File >> User Preferences і там поставте галочку на "Emulate Numpad".

Спробуйте понатискати клавіші, позначені червоним на ілюстрації:

Blender 2 5 getting started-5 1.png

Вони дають ефект наближення/віддалення та обертання по орбіті навколо центру об'єкта. «Numpad 5» перемикає між ортогональним та виглядом в перспективі (конічним). Коли переконаєтеся, що Blender в дійсності програма 3D-моделювання, можете продовжити освоєння інтерфейсу. Рушимо далі і покрутимо коліщатко миші або натиснемо на нього і почнемо рухати мишою:

Blender 2 5 getting started-5 2.pngBlender 2 5 getting started-5 3.png

На що варто звернути увагу особливо - команда File/Quit. При її виконанні Blender не запитує підтвердження або діалогу збереження сцени. Особливо небезпечним буде клац по хрестику в правому верхньому куті екрану ...

Строго кажучи, є спосіб відновити останні дані, але для цього вам доведеться самостійно знайти тимчасову директорію Blender і визначити, який із файлів відповідає останнім даними, записаним перед закриттям програми. Є ще кнопочка Recover Last Session в меню File. Єдиний спосіб уникнути цієї незручності - виконати збереження до закриття програми.

Я користуюся Blender починаючи з версії 2.32 і до цих пір не можу звикнути до відсутності попередження перед закриттям. Але все так як є.

Основні елементи[ред.]

Ви потрапили в 3D простір і тут є куб і щось на зразок сітки. Але що являють собою інші об'єкти?

Давайте подивимося:

Blender 2 5 getting started-6 1.png

Деякі назви говорять не дуже багато. Але ви шукали документ з основ Blender і хочете опанувати все швидко? Тоді давайте почнемо!

3D трансформації[ред.]

Віджети 3D-трансформацій було включено за замовчуванням у версії 2.49, але у 2.50 їх необхідно активувати для використання. Це можна зробити внизу вікна 3D-вигляду.

Blender 2 5 getting started-7 1.png

Дозволяє робити базове редагування об'єкту (переміщати, обертати, масштабувати). На початку ви переміщалися в 3D просторі, тепер переміщатися буде тільки об'єкт. Перемістіть мишкою одну зі стрілок навколо об'єкта.

Уявіть собі таке: Кадр1 = початкова позиція, кінцева позиція = кадр 100 (і замість куба там космічний корабель, наприклад X-wing з зоряних війн ... )

Blender 2 5 getting started-7 2.png

І не кажіть мені, що вам ще не починає подобатися вивчати цю чудову програму ...

Елементарні способи редагування об'єктів це: переміщення, обертання і масштабування. Ви вже знаєте як переміщати об'єкт уздовж осі, давайте спробуємо його повернути. Виберіть віджет обертання:

Blender 2 5 getting started-8 1.png

Будь-яка кольорова дуга навколо об'єкта дозволить вам повернути об'єкт навколо відповідної осі. Після вивчення цих основних прийомів трансформації об'єктів пропоную поекспериментувати в такому порядку:

  • Опція трансформації, що залишилася неописаною - масштабування.
  • Ви можете поєднати всі віджети трансформації, утримуючи Shift при виборі кожного з них.
  • У всіх віджетів модифікацій є біле коло, якщо ви починаєте переміщати об'єкт, клацаючи по ньому, переміщення не буде прив'язуватися до осей.
  • Про випадаюче меню, де написано Global, поки що можна забути.
  • Будь-яку незавершену дію можна скасувати натисканням на клавішу «Esc» або правою кнопкою миші.

Після використання всіх модифікаторів ваша сцена знаходиться в зовсім непередбаченому вигляді. Тому ми виберемо File / New (Blender видалить старий документ без збереження зроблених змін і відкриє новий зі стандартними налаштуваннями середовища). Зараз ви знаходитесь в стандартній сцені, створюваній при старті програми і ми поговоримо про камеру.

Камера[ред.]

У 3D-світі має існувати принаймні одна камера, щоб Blender знав звідки і з яким параметрами робити знімок сцени (наприклад, в якому форматі, png або jpg, зберігати зображення. Ви можете розглядати сцену в русі з будь-якої сторони, але як її бачить Blender? У вигляд з камери можна потрапити натиснувши «Numpad 0»:

Blender 2 5 getting started-9 1.png

Прямокутник, описаний суцільною лінією, це сама камера, пунктирний прямокутник показує границі видимості камери (тобто те що ми будемо бачити в готовому кадрі). Давайте зробимо «фотографію» сцени. Найпростіший спосіб - натиснути F12 ... і ввввуалллляяяяя!

Blender 2 5 getting started-9 2.png

Це саме те, що називають «Рендер». Забудьте про ідею обертати сцену у вікні рендера. Це кінцеве зображення, кадр, таке ж як ви отримуєте роблячи знімки цифровим фотоапаратом.

Зауважте, що найбільш освітлені частини в сцені знаходяться прямо перед джерелом світла. У нашій сцені лише одне джерело (лампа), про це свідчить абсолютно чорна неосвітлена частина об'єкта.

Аж до версії 2.49 рендеринг відбувався в окремому вікні. Але цю поведінку можна було змінити і зробити схожою на поведінку 2.50, де рендеринг відбувається у вікні редактора зображень UV, розгорнутому на все робоче середовище програми (не турбуйтеся, ми не збираємося вдаватися в технічні подробиці). Для повернення в робочий вигляд натисніть клавішу «Esc» (не клацайте по хрестику «Закрити Вікно»).

Панель Кнопок[ред.]

Давайте розглянемо вміст розділу крайнього праворуч вікна. Тут є велика кількість різних кнопок налаштувань. Давайте розглянемо основні з них і постараємося отримати потрібний нам результат. Іконки зверху дозволяють перемикатися між різними розділами вікна кнопок. Цей розділ зазвичай вибраний під час запуску програми:

Blender 2 5 getting started-10 1.png

Ви вже знаєте що таке рендер і вам буде досить просто розібратися в налаштуваннях цього розділу.

З наступних іконок ми зупинимося на восьмій.

Якщо ви нічого не змінювали, то у вас у вікні 3D-Вигляду куб обведений рожевим кольором. Це означає, що цей об'єкт вибраний. І в розділі «Матеріали» ви побачите наступне:

Blender 2 5 getting started-10 2.png

У цьому розділі нас цікавить панель Preview (попередній перегляд) і закладка Diffuse. Клацніть по колірному прямокутнику і відкриється редактор, в якому ви зможете вибрати потрібний колір та інтенсивність (контролюється обертанням коліщатка миші).

Blender 2 5 getting started-11 1.png

Можливий результат.

Blender 2 5 getting started-11 2.png

Ви, звичайно, можете розважити себе кількома рендерами (F12) з різними налаштуваннями матеріалу, але я думаю пора почати забувати про просту сцену з кубом. Поки куб виділений (обведений помаранчевим контуром) натисніть клавішу «Delete» та підтвердьте видалення.

Blender 2 5 getting started-11 3.png

Додавання об'єктів[ред.]

Заздалегідь визначені об'єкти в 3D програмах називаються примітивами. Деякі з них представляють собою прості геометричні об'єкти. А деякі можуть бути подарунком для програмістів готових експериментувати з програмою, але не займаютись моделюванням. Переключіть вікно 3D-вигляду на вигляд зверху (Numpad 7) і клацніть лівою кнопкою миші в центрі вікна. Це перемістить 3D-курсор в місце розташування курсора миші.

Blender 2 5 getting started-12 1.png

Це важливо, тому що при створенні нового об'єкта Blender розмістить його саме в тому місці сцени, де розташований 3D-курсор. Саме час перейти до меню Add / Mesh / Monkey.

Blender 2 5 getting started-12 2.png

Спробуйте покрутити і попереміщувати навколо сцени. Отримуйте задоволення від процесу:)

Blender 2 5 getting started-12 3.png

Цей об'єкт є талісман програми і називається Suzanne. Стривайте, час бігти і дзвонити своїм друзям з розповіддю про те, які чудові речі ви вмієте робити, ще не настав (не турбуйтеся, ви зробите це трохи пізніше).

Ви напевно захочете змінити колір матеріалу, як ми це робили з кубом. Але не лякайтеся, якщо при переході до розділу матеріалів ви побачите таке ...

Blender 2 5 getting started-13 1.png

... просто натисніть на кнопку New і перед вами відкриється весь набір кнопок, які були при роботі з кубом.

А як же рендер? Не пропускайте цей етап, це задоволення за яке не потрібно платити:). Не турбуйтеся якщо у вас виходить щось таке:

Blender 2 5 getting started-13 2.png

Погана постановка світла та камери привели до не зовсім зрозумілого результату рендерингу. Це трапилося через видалення попереднього об'єкта і додавання Suzanne без перевірки положення камери і світла відносно нього. Для виправлення ситуації нам потрібно перемістити і повернути Suzanne за допомогою 3D-віджетів Модифікації (наприклад, з вигляду з камери «Numpad 0»). Постарайтеся домогтися гарного вигляду в камері і правильного падіння світла на мавпочку. Має вийти щось на зразок цього:

Blender 2 5 getting started-14 1.png

Правильніше буде повернути камеру. Можна повертати камеру вручну, але є 2 чудових способи. Спочатку просто поверніть вигляд за допомогою коліщатка миші так, як вам подобається, потім просто натисніть ctrl + alt + num 0 - активна камера переміститься так, щоб відобразити саме той ракурс який ви обрали. Але можливо, деякі деталі опиняться поза прямокутником рендера. Врятувати ситуацію допоможе Shift + f. Якщо натиснути його з камери, ви перейдете в режим польоту: керуючи мишкою та клавіатурою, можна плавно переміщати камеру до тих пір, поки ви не натиснете ЛКМ, щоб застосувати нове положення камери і ПКМ, щоб скинути переміщення.

Покращуємо зовнішній вигляд Меша (MESH)[ред.]

Blender 2 5 getting started-14 2.png

У лівій частині інтерфейсу є ще одна чудова панель з кнопками. Ця панель стає видимою або невидимою за допомогою розділу меню View/Toolbar. Але набагато зручніше користуватися клавішею «T» (переконайтеся що курсор миші знаходиться над вікном 3D-вигляду).

Кнопка, яку вам слід натиснути, називається Smooth. Вигляд об'єкта значно поліпшиться:

Blender 2 5 getting started-14 3.png

Об'єкт перестав складатися з плоских граней (фасетний вигляд) і став гладеньким. Для повернення до фасетної версії об'єкта досить натиснути кнопку Flat (але в нашому випадку це не потрібно).

Саме час активувати шосту кнопку в Вікні Кнопок і натиснути Add Modifier. Після додавання модифікатора буде доступно меню для вибору рівня Підрозділення Поверхні (Subdivision Surface):

Blender 2 5 getting started-15 1.png

На панелі кілька кнопок і полів з цифровими значеннями параметрів.

Blender 2 5 getting started-15 2.png

Подивіться на вашу модель і оцініть результат. Кожна грань була поділена на 4 (ми не бачимо цього напряму, але можемо оцінити ефект за більш гладкою формою і поліпшенням якості об'єкта).

Blender 2 5 getting started-16 1.png

Поле «View: 1» відноситься до рівня підрозділення, який ми бачимо у вікні 3D-вигляду. У нашому випадку це рівень 1. Поле «Render: 2» відноситься до рівня підрозділення, що застосовується під час рендеру об'єкта.

Причини появи цих двох окремих параметрів прості: більша кількість граней, створюваних при підрозділі більш високого рівня, вимагає більше ресурсів від вашого комп'ютера. Логічно було б працювати з меншим рівнем підрозділу об'єкта, а рендер здійснювати з більшим. Але врахуйте, практично ніхто не використовує рівні підрозділення більше 3 ні для роботи ні для візуалізації.

Рівень підрозділення View рівний 2 поділить одну грань на 16. Спробуйте зробити рендеринг з рівнем підрозділення 2 і 3.

Blender 2 5 getting started-17 1.png

Ось і прийшов час подзвонити вашому братові або другові. Ви безумовно залишите його з відкритим ротом показавши свою роботу!

Управління виглядом з камери[ред.]

Перш ніж продовжити, я б хотів зупинитися на одній важливій речі. Найбільш зручний спосіб виставити потрібний вигляд для візуалізації - це обертати сцену і, вибравши найкращий вигляд, спозиціонувати камеру в цьому місці. Для цього є команда View/Align View/Align Active Camera to View або швидкий спосіб, натиснувши «Alt + Ctrl + Numpad 0».

Blender 2 5 getting started-18 1.png

Один з можливих варіантів:

Blender 2 5 getting started-18 2.png

Зауважте, що контур камери став помаранчевого кольору. Це може мати кілька значень:

  • Команда видалення («del») призведе до видалення камери зі сцени (не робіть цього, нам потрібна камера щоб мати точку вигляду для рендеру зображення. Якщо все ж таки ви це зробили, натисніть «Ctrl + Z» і відмініть останню дію)
  • Один з параметрів, який може вас зацікавити на даному етапі - управління фокальною відстанню камери. Цей параметр ми можемо знайти на панелі, що викликається з меню View/Properties або після натискання клавіші «N» (при натисканні N курсор миші повинен бути над вікном 3D-вигляду). Параметр називається «Lens».
Blender 2 5 getting started-19 1.png

Виділення[ред.]

Як нам виділити ще й лампу? У Blender виділення проводиться правою кнопкою миші і, як і в інших програмах, для виділення декількох об'єктів вам потрібно утримувати клавішу «Shift».

Blender 2 5 getting started-19 2.png

На ілюстрації ви бачите три виділених об'єкта: Камера, Suzanne і лампа. Я думаю, ви помітили злегка різний відтінок помаранчевого по контуру різних об'єктів. Більш насичений помаранчевий колір позначає останній вибраний об'єкт (на цей раз це лампа).

Останнє зауваження ОСОБЛИВО ВАЖЛИВО. У більшості випадків останній об'єкт буде домінантним при виконанні різноманітних дій з групою об'єктів. Зараз ми не будемо загострювати на цьому увагу, але запам'ятайте це! Якщо ви зайдете в розділ Object в Вікні Кнопок (див. нижче) ви можете побачити який з вибраних об'єктів є домінантним. В даному випадку це об'єкт Lamp.

Blender 2 5 getting started-20 1.png

Але нам зараз цікава не панель з кнопками. Ви можете помітити нову іконку, схожу на спалах, яка дозволяє контролювати світлову пляму:

Blender 2 5 getting started-20 2.png

Ви можете змінювати значення Energy (енергія), вибрати колір світла (тим же способом, як ми робили це з кольором матеріалу) або поекспериментувати з різними типами освітлення від різного типу ламп: Point (точка), Sun Spot (сонячна пляма), Hemi ( м'яке світло) або Sun (сонце).

Копіювання об'єктів[ред.]

Один або кілька виділених об'єктів можуть бути продубльовані командою Object/Duplicate або поєднанням клавіш «Shift + D».

Blender 2 5 getting started-21 1.png

Ми використовуємо цей спосіб для створення в сцені схеми освітлення з трьох джерел світла (ламп).

Blender 2 5 getting started-21 2.png

Напевно ви помітили, що всі копії мають ті ж параметри Energy і колір, що й первісна лампа.

Тепер виберіть всі лампи одну за одною, перемістіть їх, змініть параметри енергії та кольору (можна всі лампи зробити білими). Одне зауваження, постарайтеся зробити так, щоб сумарна енергія всіх трьох ламп була близька до 1.

Blender 2 5 getting started-22 1.png

Режим Редагування[ред.]

Ми вже досить багато попрацювали з Suzanne. Створіть нову сцену і ми скористаємося новим способом для зміни форми куба: Режимом Редагування (Edit mode). Найбільш швидкий спосіб перейти в режим редагування - натиснути клавішу «Tab», перевіривши, щоб куб був виділений, і курсор миші перебував у вікні 3D-вигляду.

Blender 2 5 getting started-22 2.png

Цей спосіб редагування дозволяє працювати окремо з кожною вершиною (Vertexes), кожним ребром (edges) і гранню (faces). Виділення вершин проводиться так само, як і в об'єктному режимі, по клацанню правою кнопкою миші (білий колір вершини означає, що вона обрана). Виберіть вершину і перемістіть її (так само як і об'єкт, натиснувши клавішу «G»).

Blender 2 5 getting started-23 1.png

Я використовую цю можливість для деякого розширення знань про маніпуляції з об'єктами:

Blender 2 5 getting started-23 2.png
  • Якщо ви перемістите курсор миші на біле коло 3D-віджета і «захопите» об'єкт лівою кнопкою миші за це коло, то об'єкт буде переміщатися в площині вигляду, в якому ви зараз перебуваєте (у площині монітора, якщо так буде зрозуміліше).
  • Клавіша «G» дає команду переміщати вибраний об'єкт у площині поточного вигляду (як в Режимі Редагування, так і в Об'єктному Режимі). Це означає, що відразу після натискання цієї клавіші об'єкт починає переміщатися разом з переміщенням миші. Доброю звичкою стане поміщати курсор миші поруч з об'єктом, який ви хочете переміщати, до натискання клавіші «G». Для обмеження переміщення об'єкта по певній осі, ми, після натискання на «G», натискаємо клавішу, відповідну потрібної осі XYZ. Спробуйте виділити дві вершини на одній грані, натиснути клавішу «G» й одразу за цим натиснути клавішу «Z». При русі миші обидві вершини будуть переміщатися тільки по осі Z (приклад на ілюстрації):

Якщо ви освоїли процедуру переміщення вершин, спробуйте покрутити їх за допомогою клавіші "R" і масштабувати за допомогою «S». Обмеження дії по осях також працює і для цих типів редагування.

Якщо ви спробували редагувати кілька вершин, можливо ви відчули, що не все піддається контролю і переміщається / обертається куди б хотілося. Не хвилюйтеся, ми будемо обговорювати це пізніше.

Опорна точка для обертання і масштабування[ред.]

Процедури обертання і масштабування безпосередньо залежать від точки, щодо якої вони проводяться.

Blender 2 5 getting started-24 3.png

За замовчуванням опорною точкою для цих операцій є точка Центру об'єкта, представлена ​​жирною помаранчевою крапкою.

Коли об'єкт з'являється в сцені його Опорна Точка знаходиться в геометричному центрі цього об'єкта. Якщо ми переміщуємо об'єкт в Об'єктному Режимі його опорна точка так само переміщується. Але якщо ми перемкнемось в режим редагування, виділимо всі точки об'єкту і перемістимо їх, то зможемо помітити що опорна точка об'єкта залишилася на старому місці.

Blender 2 5 getting started-24 1.png

Ми можемо повернути крапку в потрібне місце, але іноді положення опорної точки поза об'єктом використовується з особливими цілями.

У попередньому випадку ми б зіткнулися з «неправильним» обертанням об'єкта при використанні модифікатора Rotate в Об'єктному Режимі ...

У Режимі Редагування положення опорної точки і об'єкта в більшості випадків не впливає на поворот і масштабування вершин, ребер і граней. За замовчуванням, всі операції проводяться щодо геометричних центрів вибраних елементів меша.

Blender 2 5 getting started-24 2.png

Для управління положенням центра об'єкта скористаємося інструментом «Set Center». Для цього перейдіть на Панель Інструментів і в розділі «Tool Shelf» (ви напевно пам'ятаєте, що Панель Інструментів доступна після натискання клавіші «T») виберіть «Add Tool» (для прискорення пошуку ви можете скористатися новим пошуковим інструментом внизу вікна).

Blender 2 5 getting started-25 1.png

Нова кнопка (також я рекомендую спробувати поєднання клавіш «Shift + Ctrl + Alt + C», яке дозволить вам вибрати між трьома варіантами дій з опорною точкою об'єкта):

  • ObData to Center: переміщає об'єкт без переміщення його центру
  • New Center: переміщає центр об'єкта без переміщення самого об'єкта (ця операція повинна виконуватися в об'єктному режимі, інакше Blender видасть помилку виконання команди)
  • Center Cursor: переміщає центр об'єкта в місце розташування 3D-курсора (ця операція повинна виконуватися в Об'єктному Режимі, інакше Blender видасть помилку)

Але є й інші опції точок повороту в цьому випадаючому меню:

Blender 2 5 getting started-25 2.png

На цьому етапі варто приділити особливу увагу експериментам для найкращого розуміння роботи інструментів Blender.

EXTRUSION (видавлювання): найбільш потужна зброя 3D-моделювання[ред.]

Я вразив вас, чи не так?

Серйозно, те що я сказав в заголовку розділу чиста правда. Я б навіть сказав що розвиток 3D технології був би неможливий без механізму видавлювання. Не вірите мені? Давайте самі побачимо.

Запустіть Blender і виділіть куб. У Режимі Редагування виділіть у куба одну грань. У вас є кілька способів зробити це:

Blender 2 5 getting started-26 1.png
  • Виділити вершини, що утворюють грань (vertexes)
  • Виділити ребра грані (edges)
  • Виділити саму грань (face)

У нашому випадку я раджу вибрати останнє.

Blender 2 5 getting started-26 2.png

Для виконання операції видавлювання (так, я знову не розповів що ж таке «видавлювання», але я хочу зробити вам сюрприз) виконайте команду Mesh/Extrude, але я б рекомендував скористатися гарячою клавішею «E». Потім перемістіть мишу і завершіть операцію клацанням лівої кнопки миші.

Якщо демонстрація цих можливостей не «зачепить» вашого друга, я готовий викинути рушник і здатися разом з вами.

Пограйте з виділенням граней і їх видавлюванням. Зробіть що-небудь, схоже на реальні об'єкти. Насолоджуйтеся!

Ви вже повинні відчути себе комфортно при роботі з мешом об'єкта.

Тут би я хотів трохи зупинитися і розповісти про дві речі:

  • Ви можете вмикати і вимикати напівпрозорість об'єкта натисканням кнопки праворуч від типу обраного об'єкта (у нашому випадку грані).
Blender 2 5 getting started-27 1.png
  • Ви можете перемикатися між різними способами відображення об'єкта. Один з них «Каркасний» (WireFrame). Вибір між ними здійснюється в цьому меню:
Blender 2 5 getting started-27 2.png

Два найбільш часто використовуваних при редагуванні способу відтворення об'єкта - «Каркасний» (WireFrame) та «Твердотільний» (Solid). Переключення між ними відбувається натисненням клавіші «Z».

Додавання меша на сцену, де вже є інші[ред.]

Напевно ви скажете - «Це ж дуже просто! Потрібно зайти в меню Add і вибрати потрібну форму із Mesh».

Тут я б хотів звернути вашу увагу на одну дуже важливу річ. Якщо ви додаєте меш в Об'єктному Режимі - буде створено новий об'єкт окремий від усіх інших. Якщо ж ви додаєте меш в Режимі Редагування він стане частиною об'єкта, в режимі редагування якого ви знаходитесь. У прикладі нижче куб був створений в режимі редагування UV-сфери:

Blender 2 5 getting started-28 1.png

Це означає, що:

  • Обидва меші будуть мати спільний центр.
  • Ви не можете переміщати ці Меші окремо в Об'єктному Режимі (при виділенні куба буде автоматично виділено і сферу, як і навпаки):
Blender 2 5 getting started-28 2.png
  • Всі властивості одного меша поширюються і на інший. Взагалі то, строго кажучи, нічого не поширюється. Я повторюся ще раз: обидва меші являють собою єдиний об'єкт.
Blender 2 5 getting started-29 1.png

Напевно вам би хотілося зробити обидва меші незалежними об'єктами. Давайте розділимо (separate) їх. Найбільш зручний спосіб це зробити - перейти в режим редагування і виділити хоча б одну вершину меша. Виконати команду Mesh/Vertices/Separate або скористатися гарячою кнопкою «P». Blender попросить вас вказати критерії поділу об'єкта.

Blender 2 5 getting started-29 2.png

У даному випадку виберемо «By loose parts» що призведе до виокремлення всіх не зв'язаних частин.

Зворотна операція об'єднання робиться з Об'єктного Режиму. Виділіть об'єкти, які хочете об'єднати, і дайте команду Object/Join або натисніть кнопку «Ctrl + J».

Виділення всього[ред.]

У Режимі Редагування і в Об'єктному Режимі для виділення або зняття виділення з усіх об'єктів ви можете використовувати команду «Select/Select-Deselect All» але я рекомендую освоїти клавішу «A».

Ще дещо про матеріали[ред.]

Давайте знову повернемося до налаштувань матеріалів у Вікні Кнопок, і спробуємо з'ясувати, які ще властивості ми зможемо до них застосувати.

Я припускаю, що сцена залишилася в стані, в якому ми залишили її відразу після наших експериментів з поділом і об'єднанням. У нас два окремих об'єкти, але так як вони були одним цілим, вони обидва використовують один і той же матеріал для меша. При зміні налаштувань матеріалу для UV-сфери, налаштування матеріалу куба зміняться таким же чином.

Перейдіть в розділ матеріалів і зверніть увагу на цифру 2 праворуч від назви матеріалу. Ця кількість об'єктів, що використовують цей матеріал. Якщо ви клацнете по цьому числу, то для вибраного об'єкта буде створена окрема копія матеріалу і зміна налаштувань не буде впливати на матеріали інших об'єктів.

Blender 2 5 getting started-30 1.png
Blender 2 5 getting started-30 2.png

Тепер, перейшовши в Об'єктний Режим, створіть площину і скомпонуйте об'єкти, як це зроблено в ілюстрації (у сцені використовується 3 джерела світла):

Blender 2 5 getting started-31 1.png

На завершення у вас має вийти рендер, близький до цього:

Blender 2 5 getting started-31 2.png

Виберіть площину і перейдіть в розділ редагування матеріалів. Ми хочемо отримати дзеркальну поверхню і для цього нам потрібно знайти панель Mirror.

Blender 2 5 getting started-31 3.png

Першим кроком буде активувати її. Нам стануть доступні параметри для налаштування «дзеркальності» матеріалу:

  • Reflectivity: дзеркальність (ступінь віддзеркалення світла)
  • Fresnel: параметр, що вживається для матеріалів нерівномірно дзеркальних по своїй поверхні (наприклад, скляний келих віддзеркалює тільки ближче до краю)
  • Fade to Material: не затемнювати колір неба (далі ми більш детально розглянемо цей параметр)
  • Gloss: параметр «чистоти» віддзеркалення. Робить об'єкт не зовсім реальним, але як і раніше віддзеркалює.
Blender 2 5 getting started-32 1.png

Насолоджуйтесь новими можливостями. Пам'ятайте, віддзеркалення в значній мірі відображає світіння неба, і колір неба буде впливати на остаточний рендер.

Blender 2 5 getting started-32 2.png

Тепер виберемо куб і в розділі матеріалів активуємо параметр Transparency (прозорість).

Blender 2 5 getting started-33 1.png

Нам будуть доступні наступні параметри:

  • Raytrace: прозорість, отримана за допомогою цього способу (не Z-transparency), дає більш якісне зображення і надає більшу кількість параметрів для імітації реальних оптичних ефектів. Але даний спосіб вимагає значно більших системних ресурсів.
  • Alpha: ступінь прозорості
  • IOR: ступінь заломлення об'єктів при спостереженні їх через прозорий об'єкт
  • Gloss: дає той же ефект, як і при створенні дзеркальної поверхні
Blender 2 5 getting started-33 2.png

Я думаю, мені варто залишити вас на деякий час і дати можливість поекспериментувати з усіма цими чудовими параметрами.

Колір неба[ред.]

За замовчуванням колір неба сірий, але він може бути змінений за смаком. Все що потрібно зробити - вибрати колір, подібно матеріалу. Це можна зробити з розділу World в Вікні Кнопок:

Blender 2 5 getting started-34 1.png

Ще трохи про освітлення[ред.]

У попередньому випадку всі об'єкти відкидали по кілька тіней. Але, можливо, ви помітили, що не всі з трьох джерел світла створювали тіні у об'єктів.

Програма, що використовується для прорахунку всіх цих аспектів називається «трасирувальник променів» (Raytracer). Для ламп, що випускають світло але не створюють тіней від об'єктів, функцію «Ray Shadow» слід відключити. Ці функції ви можете знайти в Вікні Кнопок в розділі матріалів при обраному джерелі освітлення.

Blender 2 5 getting started-34 2.png

Якщо б у попередній сцені лише одне джерело світла створювало тіні від об'єктів, результат був би таким:

Blender 2 5 getting started-35 1.png

Набагато краще. Але якщо подивитися на предмети в реальному житті, тіні втрачають контрастність границь при віддалені від об'єкту. Наші тіні виглядають занадто штучно. Для додання їм більшої реалістичності давайте поміняємо параметри на панелі трохи нижче:

Blender 2 5 getting started-35 2.png
  • Soft Size відноситься до розміру розмиття
  • Samples - кількість тіней, яку буде прораховувати Blender для заповнення зони розмиття.
Blender 2 5 getting started-35 3.png


Цей тип освітлення найбільш близький до часто використовуваного в 3D Ambient Occlusion (навколишнього освітлення), яке не вимагає створення джерел (але для створення тіней додають один або два).

Але до застосування Ambient Occlusion нам потрібно вибрати кожен об'єкт, і в Вікні Кнопок в розділі Матеріали клацнути по хрестику поруч з назвою матеріалу, присвоєного цьому об'єкту. Ambient Occlusion підтримує і прозорість і віддзеркалення, але час рендеру буде нескінченним.

Blender 2 5 getting started-36 1.png

У цьому прикладі я вилучив всі джерела світла.

Blender 2 5 getting started-36 2.png

Для досягнення ефекту навколишнього освітлення нам потрібно в Вікні Кнопок зайти в розділ World і активувати Ambient Occlusion.

Blender 2 5 getting started-36 3.png

Зверніть увагу на:

  • Raytrace та Approximate. Approximate краще використовувати для отримання скетчів сцени.
  • Samples: навколишнє освітлення створює в сцені текстуру з шумом. Велика кількість маленьких частин.
  • Enerdy: кількість випроміненого світла (цими частинами)

Світло йде з усіх боків і створює дуже приємний естетичний ефект.

Blender 2 5 getting started-37 1.png

Процедурні текстури[ред.]

Це теж ті ж текстури, але взяті не із зображень, а згенеровані комп'ютером за певним алгоритмом (процедурою). У план цього опису не входить глибоке вивчення текстур. Тому я дам лише декілька підказок для самостійного освоєння цієї функції.

Почніть зі створення UV-сфери, згладьте її застосувавши Smooth, Перейдіть в розділ Матеріалів і призначте один для сфери. Це призведе до появи ще однієї іконки праворуч від іконки розділу Матеріалів. Цей розділ містить інструменти додавання і створення текстур.

Blender 2 5 getting started-37 2.png

Коли ви клацнете по кнопці «New» нижче з'являться параметри налаштування текстури. У випадаючому меню Type, де зараз стоїть Clouds виберіть Marble і ви побачите великий набір параметрів для налаштування граніту.

Blender 2 5 getting started-38 1.png

Нижче приклад рендеру з увімкненим Ambient Occlusion і невеликими налаштуваннями відблисків:

Blender 2 5 getting started-38 2.png
Blender 2 5 getting started-38 3.png

Сірий відтінок відноситься до того кольору, який був обраний в якості матеріалу для сфери. Але призначена текстура використовує два кольори і Blender підставляє в якості другого кольору якийсь відтінок «за замовчуванням». Вибрати другий колір ви можете в блоці кольору під кнопками налаштування текстури:

Виберіть другим кольором щось трохи темніше кольору матеріалу:

Blender 2 5 getting started-39 1.png

Саме час пограти з кольорами текстури і зробити кілька рендерів:

Blender 2 5 getting started-39 2.png

Ви можете додати кілька текстур на один і той самий об'єкт.

Додавання колірних карт[ред.]

Зараз ми додамо цю колірну карту на площину:

Blender 2 5 getting started-39 3.png

Створіть сцену і розмістіть об'єкти як на ілюстрації:

Blender 2 5 getting started-40 1.png

Тут одна горизонтальна площина, що представляє землю і одна вертикальна площина, на одну із сторін якої ми накладемо зображення.

Додайте вертикальній площині матеріал так само, як попередньому об'єкту. Але тепер у меню, виберіть не Marble а Image or movie. Серед інших параметрів буде виклик файл-менеджера для пошуку і завантаження зображення з вашої домашньої директорії.

Blender 2 5 getting started-40 2.png

Першим результатом буде ось це:

Blender 2 5 getting started-40 3.png

Зображення може виявитися перевернутим через накладення на зворотну сторону площині.

Зробивши деякі налаштування текстур і матеріалів для обох площин і додавши Ambient Occlusion ви можете отримати, наприклад, ось такий результат:

Blender 2 5 getting started-41 1.png

Що вам слід знати про рендери[ред.]

На даний момент нас цікавить не дуже багато. У міру набуття досвіду багато речей стануть зрозумілими самі по собі. Давайте зараз подивимося на самі панелі Рендеру. Перше, що ви тут бачите і є найважливіше:

Blender 2 5 getting started-41 2.png
  • Image: еквівалент клавіші «F12» - рендер зображення
  • Display: Full Screen. Вибір вікна, в якому буде запущений рендер. Найбільш часто використовується Full Screen або New Window.
Blender 2 5 getting started-42 1.png
  • Resolution X, Y: розподільча здатність кінцевого зображення в пікселях
  • %: Розмір зображення після рендеру, у відсотках від оригінального. Зменшуйте це значення для рендеру чорнових варіантів і встановлюйте в 100% для одержання фінального зображення розміром, зазначеним у Resolution.
Blender 2 5 getting started-42 2.png
  • Anti-Aliasing: ступінь згладжування країв для того щоб позбутись класичного ефекту драбинки. Більш високе значення дає кращу якість.
Blender 2 5 getting started-42 3.png
  • Alpha: якщо ми хочемо отримати зображення з прозорим шаром, нам потрібно вказати Blender, що колір оточення (колір неба і горизонту) не повинен з'являтися на фінальному зображенні. Спочатку нам потрібно вибрати формат фінального зображення PNG (або схожий, що підтримує прозорість). Потім вибрати з Sky, Premultiplied і Straight Alpha найбільш підходящий спосіб створення прозорості. Вибір цього параметра визначає якість країв об'єктів і якість antialiasing. Зазвичай, Premultiplied дає кращий результат ніж Sky.
Blender 2 5 getting started-42 4.png
  • Шлях до директорії для збереження отриманого зображення зараз не дуже важливий - ми з вами просто розважаємося.
  • PNG є форматом кінцевого зображення за замовчуванням, але ви можете вибрати серед великої кількості інших.
  • BW, RGB і RGBA: параметри вибору між чорно/білим, кольоровим і кольоровим зображенням з каналом прозорості (alpha channel). Якщо ми хочемо отримати обговорюваний раніше ефект - нам потрібно вибрати останню опцію.

Якщо ви хочете зберегти створений рендер, у вікні з відрендереним зображенням відкрийте меню Image і виберіть пункт Save або Save as ... як і в будь-якій іншій програмі, чи не так?

Blender 2 5 getting started-43 1.png

Важливі речі[ред.]

І ще пара речей, які я вважаю важливими, перед тим як випустити вас у вільний політ.

  • Правильна організація послідовностей вершин має важливе значення при використанні модифікаторів (наприклад Subdivision Subsurf). Ці послідовності називаються «Кільця». Для зміни форми вже існуючого об'єкта використовуйте в Режимі Редагування інструмент Knife (ніж). Для цього ви можете, як у випадку з Set Center, використовувати кнопки Loopcut і Slide, або просто натиснути «Ctrl + R» (саме цей спосіб я й рекомендую вам).

Коли ви клацнете перший раз по ребру, яке збираєтеся розрізати, Blender дозволить вільно переміщувати місце розрізу вздовж по вибраному ребру.

Blender 2 5 getting started-44 1.png
  • Зазвичай, працюючи з об'єктами, ви орієнтуєтеся за глобальними осями координат X Y Z. Але в об'єкта є ще й свої «локальні» координатні вісі. Їх зручно використовувати, якщо ви вже повернули об'єкт і хочете пересунути або змаштабувати його «Вперед» по відношенню до самого об'єкту. Для цього натисніть GYY (G - щоб дати команду переміщати об'єкт, Y два рази щоб ​​переміщення відбувалося по локальній осі Y, спрямованій «вперед» по відношенню до самого об'єкту).
Blender 2 5 getting started-44 2.png

Це може допомогти і при 3D трансформаціях. Пам'ятаєте, я згадував на початку про випадаюче меню поблизу 3D?

Blender 2 5 getting started-45 1.png

Ви можете поекспериментувати з різними параметрами.

Є ще сотня речей, які я хочу вам розповісти, але я щоразу нагадую собі, що документ називається «Швидкий старт для новачків у Blender».

Хочу привітати, ви вже не новачки!

ЕПІЛОГ[ред.]

Сподіваюся мені вдалося дати вам базові знання для початку роботи з Blender. Я не збрехав, коли сказав що цей посібник описує лише 1% можливостей програми. Blender підтримує анімацію, створення відеоігор, редагування аудіо та відео ... Blender вартий того часу, який ви витрачаєте на його вивчення. Це дійсно потужний інструмент, а не просто іграшка. Якщо ви освоїте Blender, у вас з'явиться можливість створювати будь-які графічні роботи, обмежені лише фантазією.

Вітаю вас зі знайомством з цим чудовим новим світом і ... Щасливого Blend'ерингу!